7 Most Common WordPress Errors With Reason and Solution:
What is the reason for WordPress White Screen of Death (WSOD)?
- Plugin compatibility issue.
- WordPress theme compatibility issue.
How to fix WordPress White Screen of Death?
- Plugin compatibility issue: In case, there is a compatibility issue with the WordPress plugin, you can solve this by deactivating the plugins one by one. If your admin pages are frozen due to WSOD, you can deactivate them using FTP. Login using FTP, go to the location wp-content/plugins, and rename the plugin folder to deactivate the plugin.
- WordPress theme compatibility issue: White death of screen can also occur when you install and inactivate a new theme. To solve this issue, you can just activate any default WordPress theme. And again, if you don’t have access to the admin pages, log in via FTP, to go /wp-content/themes/ and rename the theme folder name.
What is the reason for the Error establishing the database connection?
- Incorrect database credentials (Database name, Database username, Database password)
- Wrong hosting information (Database host)
- Damaged database
- Server down
How to fix Error establishing database connection WordPress
- Incorrect database credentials: The most typical reason for database error is not providing the correct database credentials. Since you will not have access to your site when you get this error, you need to log in via FTP to check if the database name, username, and password are correct. You can find this information in the wp-config.php file.
- Wrong hosting information: If your database credentials are correct, then there is a possibility that your hosting information is incorrect. Usually, most hosting providers use localhost as their database host, it can be different depending on your hosting provider, so check if you are using the correct database hostname.
- Server down: Another common reason that works behind database connection error is the server down. If you have all the credentials and hosting information correct, then it is most likely your server is down. The server can be down because it has met its quota or for any other reason that you can not fix yourself. In that case, you need to contact your hosting provider for further action.
Why do you see the maintenance mode message?
- Closing your browser in the middle of auto-update
- Trying to upgrade a huge number of plugins/themes at the same time.
- Compatibility issue with theme/plugin
What causes WordPress Failed Auto-Upgrade?
- Change in file permission
- PHP memory limit exhaustion
How to solve WordPress Failed Auto-Upgrade?
- Change in file permission: Access your WordPress files through FTP and go to the /upgrade/directory folder and change its permission to 777 or CHMOD. This folder needs to be writable for a successful auto-upgrade.
- PHP memory limit exhaustion: To solve this issue, you need to increase the memory limit. You can do that by accessing the wp-config.php file in the root folder of your WordPress directory. In this file look for a line similar to define(‘WP_MEMORY_LIMIT’, ’40M’); and update the line to define(‘WP_MEMORY_LIMIT’, ‘128M’);
Final Words
Read the full article for detailed knowledge.