December 6, 2018

Problem in Installing SSL

i bought SSL in Godaddy for my site http://thelastminuteblog.com/ , but it show as "Not secure" error still. So, I contacted the Godaddy Support and they showed me a error from "Whynopadlock.com" . Below is the error message.

An image with an insecure url of "http://thelastminuteblog.com/wp-content/uploads/My-Post-6.jpg" was loaded on line: 284 of https://thelastminuteblog.com/.

This URL will need to be updated to use a secure URL for your padlock to return.

I changed the image and deleted those images several time but error is not fixed yet.

I will be appreciate if someone help me out!


  1. 4

    Hi Ela

    To answer your question:

    You're getting a mixed content error. Basically it means your page is loading content via http:// instead of https://. If you load anything via http://, the (green) padlock will not show since the page is serving insecure content

    It's not about changing the image or deleting the image it's about making sure it's loaded with a https:// address

    You're on wordpress, sometimes wordpress can be a little bit difficult with enabling/enforcing HTTPS. I know this because I've setup and hosted a couple of Wordpress sites with SSL via codemason.io (my startup)

    Make sure you've updated your WordPress Address (URL) and Site Address (URL) to be https://thelastminuteblog.com and that should fix it

    If not -- let me know and I'll try to help you dig deeper into what it could be

    Also any particular reason for purchasing a SSL cert instead of using something like LetsEncrypt which will get you a cert for free?

    1. 2

      Wow this is worked!!! Now i can see https in my URL.

      Thanks a ton!

      Regarding of LetsEncrypt, i just know about it now, will check it.

  2. 3

    You can force redirect all http traffic to https (port 80 to port 443 in technical terms) using this Wordpress plugin https://wordpress.org/plugins/force-https-littlebizzy/

    It looks like it also takes care of mixed content issues.

    Disclaimer : I don't use Wordpress and have never used this plugin (but it has high ratings) however I use this method by configuring the same setting in the NGINX web server config for all my apps.

  3. 3

    Try hosting on netifly, will make ur life so much easier

  4. 2

    I am not at my desktop computer but you can view your page source, then press ctrl+f and search for http:

    You have a non https linked resource of some kind. Try making a test page with little or no content on it and add stuff until it breaks. Or remove things until it works.

    1. 2

      To help with this comment, this is the offending snippet

      
      <a href="https://thelastminuteblog.com/" title="The Last Minute Blog" rel="home">
      
      	<img src="http://thelastminuteblog.com/wp-content/uploads/My-Post-6.jpg" class="logo-image" alt="The Last Minute Blog" />
      
      </a>
      
      

      (note: removed additional whitespaces for readability)